Thread: Myth 0.25 VAAPI E350

Reply to Thread
Results 1 to 6 of 6
  1. Default Myth 0.25 VAAPI E350 #1
    mythboy is offline MythTV Friend in Training
    Join Date
    May 2011
    Posts
    14
    MythTV Gallery
    0
    Hi guys -

    I have Ubuntu 11.10 32-bit with the latest 12.3 Catalyst fglrx drivers from ati's website, using splitted desktop's libva1 and libva1-dev drivers. My vainfo looks like this:


    libva: VA-API version 0.32.0
    libva: User requested driver 'xvba'
    libva: Trying to open /usr/lib/va/drivers/xvba_drv_video.so
    libva: va_openDriver() returns 0
    vainfo: VA-API version: 0.32 (libva 1.0.15)
    vainfo: Driver version: Splitted-Desktop Systems XvBA backend for VA-API - 0.7.8
    vainfo: Supported profile and entrypoints
    VAProfileH264High : VAEntrypointVLD
    VAProfileVC1Advanced : VAEntrypointVLD

    I'm able to run VLC with VAAPI. However when I try to utilize the VAAPI decoder in Myth .25 I get these errors:

    VAAPI: Invalid display
    VidOutGLVAAPI: Failed to create VAAPI context
    VideoOutput: Not Compiled with any useable video output method.

    Please help.



    I have a ASRock E350M1 Motherbaord which has the Zacate CPU configured to have 512mb on the GPU from the 4GB of DDR3 memory.
    Reply With Quote  

  2. Default #2
    rileyp is offline MythTV lil' Helper
    Join Date
    May 2010
    Location
    Lara Australia
    Posts
    66
    IRC Nick
    rileyp
    Distribution
    mythbuntu
    MythTV Version
    0.24 fixes
    MythTV Gallery
    0
    Your wasting your time with ati in linux. A $40 nvidia card >=9200 will solve everything and allow 1080p playback via software (vdpau) on as little as a single core atom.
    Last edited by rileyp; 04-09-2012 at 03:04 PM.


    Reply With Quote  

  3. Default #3
    wagnerrp is offline Cornerstone of the Community
    Join Date
    Mar 2010
    Posts
    2,267
    IRC Nick
    wagnerrp
    Distribution
    FreeBSD, Gentoo
    MythTV Version
    trunk
    MythTV Gallery
    0
    Quote Originally Posted by mythboy View Post
    VAProfileH264High : VAEntrypointVLD
    VAProfileVC1Advanced : VAEntrypointVLD
    Is that indicating that AMD's VAAPI implementation does not currently support accelerated MPEG2 playback?


    Reply With Quote  

  4. Default #4
    mythboy is offline MythTV Friend in Training
    Join Date
    May 2011
    Posts
    14
    MythTV Gallery
    0
    Quote Originally Posted by rileyp View Post
    Your wasting your time with ati in linux. A $40 nvidia card >=9200 will solve everything and allow 1080p playback via software (vdpau) on as little as a single core atom.
    Riley,

    I admit it is very frustrating. I'm able to get VAAPI working using OpenElect XBMC, XMBC on Ubuntu, but getting it to work on Myth is a major Pain. I found out in .25 that to get it to work I had to enable openGL as the main theme painter. However display is very unstable.

    I wish I could use an external video card but my only slot is used by my tuner card.


    Reply With Quote  

  5. Default #5
    mythboy is offline MythTV Friend in Training
    Join Date
    May 2011
    Posts
    14
    MythTV Gallery
    0
    Quote Originally Posted by wagnerrp View Post
    Is that indicating that AMD's VAAPI implementation does not currently support accelerated MPEG2 playback?
    No that just means that VAAPI drivers have been installed and VAAPI playback is possible.

    BTW, I got Myth 0.25 working with VAAPI enabled on this mobo. But in 0.25 there appears to be a bug in that IPTV UDP streams are broken when changing channels from live TV.


    Reply With Quote  

  6. Default #6
    della is offline MythTV Rookie
    Join Date
    Jun 2011
    Posts
    3
    Distribution
    Mythbuntu 11.04
    MythTV Version
    0.24.1
    MythTV Gallery
    0
    Quote Originally Posted by mythboy View Post
    No that just means that VAAPI drivers have been installed and VAAPI playback is possible.

    BTW, I got Myth 0.25 working with VAAPI enabled on this mobo. But in 0.25 there appears to be a bug in that IPTV UDP streams are broken when changing channels from live TV.
    How did you managed it? Is there something special? I also tried to get my MythTV 0.25 working with VAAPI on E450. After switching the GUI to OpenGL and creating the VAAPI playback profile, I got hardware-accelerated HD-TV. However something goes wrong with the video scaling/zoom. I can only see some small part of the video.

    Hardware-acceleated video payback work perfect in vlc and (self-compiled) mplayer.

    I am using more or less a standard mythbuntu 12.04 installation.


    Reply With Quote  

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. X desktop size vs Myth GUI size vs Myth playback size
    By snorton in forum Installation Issues
    Replies: 2
    Last Post: 07-19-2012, 09:37 PM
  2. AMD Fusion E350
    By galb in forum Hardware
    Replies: 4
    Last Post: 09-16-2011, 06:54 PM
  3. How to compile VAAPI for MythTV per bug 8593
    By mythboy in forum General
    Replies: 3
    Last Post: 08-10-2011, 12:43 AM
  4. Replies: 2
    Last Post: 06-26-2010, 07:29 AM
  5. Is VAAPI over ffmpeg possible?
    By seppl in forum Hardware
    Replies: 0
    Last Post: 06-15-2010, 06:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts