Thread: EPG Freezes

Reply to Thread
Results 1 to 6 of 6
  1. Default EPG Freezes #1
    theophile is offline Cornerstone of the Community
    Join Date
    May 2005
    Posts
    383
    MythTV Gallery
    0
    First, a point of order. I love MythTV. To all the devs and contributors, thank you from the bottom of my heart.

    Now then, one of the reasons I converted my MythTV box from Gentoo to Ubuntu was that the upgrade to 0.21 on Gentoo brought with it some bugs I was hoping would be ironed out in tested binary packages. One of these bugs, unfortunately, persists in Mythbuntu. When the EPG comes up, as soon as the tuner locks onto the signal and the video thumbnail starts playing, I can no longer navigate the EPG. Arrow keys and escape do not work. However, if I CTL+ALT+F3 (for example) to another VT and then switch back into X, the keys I pressed all take effect.

    For example, I start "Watch TV." The EPG loads and the video thumbnail starts playing. I push "left-right-left-right-left-right-leftt-right-ESC" in that order. Nothing happens. I wait. Nothing happens. Then I do CTL+ALT+F3, then CTL+ALT+F7 to get back to X. Immediately, the selection box goes back and forth very quickly a few times then the ESC key takes effect and quits the EPG.

    This happens when starting the EPG immediately upon selecting "Watch TV" and when pressing "S" to bring up the EPG while already watching TV.

    I've tried different themes and different OSD themes. I've tried changing interlacer settings, GL syncing, and every option in the Program Guide setup screen.



    I am running a purely OTA ATSC system with a pc 3000 tuner, a P4 2 Ghz, 1 GB RAM, and an nVidia 5200fx. I'm using an Olevia HDTV as a VGA monitor, if that makes any difference.

    If running mythfrontend from the terminal, I do notice some audio buffer underrun and prebuffering pause errors. Could this be related to the performance of the Myth GUI?

    Any suggestions welcome. Thanks!
    Reply With Quote  

  2. Default #2
    mharter is offline MythTV Rookie
    Join Date
    Jul 2008
    Posts
    1
    MythTV Gallery
    0
    I seem to be having the same problem, except my problem only happens on certain atsc channels. something about one of my channels causes the program guide to do nothing. Then if i ctrl+alt+f1 and go back to x I can watch the keystrokes happening.

    Did you ever find a solution to your problem?


    Reply With Quote  

  3. Default #3
    theophile is offline Cornerstone of the Community
    Join Date
    May 2005
    Posts
    383
    MythTV Gallery
    0
    I've been doing a lot of work to try to speed up my system, including installing the nvidia drivers through Envy and adding and enabling features, reinstalling DRI, the works.

    Not only has this helped playback performance, it has eliminated that EPG issue. I wish I could tell you what specifically fixed it, but I just threw the book at my mythbox.

    Eventually, once I get everything working right, I'll make a post explaining everything I did, mainly for my own future reference.


    Reply With Quote  

  4. Default #4
    fromans4's Avatar
    fromans4 is offline Cornerstone of the Community
    Join Date
    Aug 2005
    Location
    Petaluma, California
    Posts
    1,196
    Distribution
    Ubuntu
    MythTV Version
    .23
    MythTV Gallery
    1
    I had a similar problem with the EPG shortly after upgrading to MythTV .21. I ended up having to change my TV settings to not use any xv stuff at all and I also switched from GL to QT painter. I have not had any issues since then.

    Brent


    Please mark thread as solved if you consider this to have answered your question(s)
    Just go to Thread Tools -> Mark this thread as solved.
    Reply With Quote  

  5. Default #5
    theophile is offline Cornerstone of the Community
    Join Date
    May 2005
    Posts
    383
    MythTV Gallery
    0
    Yeah, I'm back to the same problem again. My upgrades broke XvMC but fixed the problems I was having with ffmpeg and xv. Except now my EPG issues are back.

    I'm installing the nightly builds now, hoping it may fix the problem and hoping upon hope that it doesn't hose my setup...


    Reply With Quote  

  6. Default #6
    theophile is offline Cornerstone of the Community
    Join Date
    May 2005
    Posts
    383
    MythTV Gallery
    0
    Well I don't seem to have any viable rendering option besides xv so I have to nail this down. As a workaround, I have found that if I pause playback before going into the EPG, there are no problems.

    I really don't need playback in a tiny square in the EPG. Especially with HD, where the aspect ratio is all out of whack and it skips and stutters anyway, I'd rather just have it stop playback and give a full screen view of the EPG.

    Is it possible to set up Myth to use the same EPG screen as the one the appears under the schedule recordings menu (i.e. sans embedded playback)?


    Reply With Quote  

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Mythtv freezes when looking for tv cards
    By hairy in forum Installation Issues
    Replies: 6
    Last Post: 10-16-2010, 05:12 AM
  2. playback freezes
    By majatalo in forum General
    Replies: 0
    Last Post: 06-03-2008, 08:59 PM
  3. TV freezes at end of recording
    By Lorian in forum General
    Replies: 3
    Last Post: 01-12-2007, 09:00 AM
  4. systems freezes cause bad superblock on JFS
    By blawson in forum General
    Replies: 8
    Last Post: 10-06-2005, 06:57 PM
  5. Live TV freezes
    By scovel in forum General
    Replies: 7
    Last Post: 09-08-2004, 09:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts