Thread: DVB-T: Missing EPG on SOME channels - not all.

Reply to Thread
Results 1 to 5 of 5
  1. Default DVB-T: Missing EPG on SOME channels - not all. #1
    smartysmart34 is offline MythTV Friend in Training
    Join Date
    Jun 2008
    Posts
    9
    MythTV Gallery
    0
    Hi all,

    I set up a mythtv-box some 4 weeks ago. It uses a USB dvb-t stick and I was able to scan for channels, set them up and watch them live. They ALL delivered EPG data (EIT) and I was able to use this to record shows. All fine so far.

    Now I realised that some (only 4 out of 12) channels are missing EPG data. Well at least mythtv doesn't show it anymore. I can still watch these channels in Live TV. But neither the OSD nor the Program Overview in the "Plan Recording" menu shows any data. In the program overview all it says for these chanels is "Unknown".



    I tested these channels with a second DVB-T stick on my laptop: With kaffeine they can be watched live and there is EPG data (at least for the current show). So the station is sending EPG data.

    So as a summary:
    - The station is sending EPG data
    - Mythtv is able to show the channel in Live-TV
    - Mythtv in general is able to show EPG data - as it does with all the other channels
    - Mythtv is just not able to show EPG for those specific channels anymore. Used to work until about a week ago.

    As expected Mythfilldatabase ignores these channels as they are configured to use EIT.

    What would be the best way to fix it? Where should I look? Any hints, ideas or links?
    What else do you need to help me?

    Platform: OpenSuse 11.4/32bit
    Mythtv from Packman-Repository - Latest stable version

    Kind regards,
    Martin
    Reply With Quote  

  2. Default #2
    wagnerrp is offline Cornerstone of the Community
    Join Date
    Mar 2010
    Posts
    2,261
    IRC Nick
    wagnerrp
    Distribution
    FreeBSD, Gentoo
    MythTV Version
    trunk
    MythTV Gallery
    0
    There are two different EIT modes, active and passive. Active means the EIT scanner will kick in and start pulling guide data any time the tuner is inactive for a few minutes. Passive means it will only attempt to extract EIT data from existing scheduled recordings and Live TV sessions. If you have it set to passive, and simply haven't used those channels in several days, they could have run empty of EIT data. If you only recorded data very briefly in Live TV mode to check the OSD, it may not have had sufficient time to receive a full data packet to decode and apply to the database.


    Reply With Quote  

  3. Default #3
    smartysmart34 is offline MythTV Friend in Training
    Join Date
    Jun 2008
    Posts
    9
    MythTV Gallery
    0
    Could you give me a short hint as to where that setting can be found? I assume it is in the backend-setup?

    Kind regards,
    Martin


    Reply With Quote  

  4. Default #4
    smartysmart34 is offline MythTV Friend in Training
    Join Date
    Jun 2008
    Posts
    9
    MythTV Gallery
    0
    Hi, I just checked. I can't find any option to switch from active to passive or vice versa. Actually there is no option even remotely looking like that. The only thing I found was "use DishNet long term EIP". But I think that's something different?
    I watched Live-TV on one of the affected channels for about 5 minutes. But it still has no EPG data for that channel. How long would it need for the passive EIT to kick in and collect data?


    Reply With Quote  

  5. Default #5
    PhilB is offline MythTV Helper
    Join Date
    Feb 2009
    Location
    South West London
    Posts
    186
    Distribution
    Mythbuntu 12.04
    MythTV Version
    0.25
    MythTV Gallery
    0
    I found this an interesting thread as I've had this problem after rescanning channels with guide population taking about a week.

    Does this give clues?
    http://linuxtv.org/wiki/index.php/Ha...nTV-NOVA-T-500
    Do a find on word active

    Regards
    Phil


    Reply With Quote  

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. missing channels above 13 (UK)
    By RobPotts in forum General
    Replies: 1
    Last Post: 04-15-2010, 06:57 PM
  2. Missing channels
    By Azelphur in forum Installation Issues
    Replies: 3
    Last Post: 04-14-2010, 01:08 AM
  3. Missing cable channels
    By fencerf in forum General
    Replies: 4
    Last Post: 08-25-2008, 12:19 PM
  4. Missing channels PVR-150 Ubuntu
    By Glimps in forum Ivtv Issues
    Replies: 1
    Last Post: 05-01-2007, 02:42 PM
  5. Missing Channels
    By rengor in forum General
    Replies: 0
    Last Post: 09-04-2006, 09:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts