Thread: Die Karte treibt mich zur Verzweifelung (Hauppauge PVR 350)

Reply to Thread
Results 1 to 3 of 3
  1. Default Die Karte treibt mich zur Verzweifelung (Hauppauge PVR 350) #1
    lines is offline MythTV Friend
    Join Date
    Nov 2005
    Location
    Ruhrgebiet
    Posts
    30
    MythTV Gallery
    0
    Manchmal haben PC-Karten doch ein Eigenleben. Leider treibt mich das meiner neuen Hauppauge PVR 350 zur Verzweifelung. Sie möchte einfach nicht laufen. Die Karte ansich ist in Ordnung, da sie unter Windows funktioniert.



    Folgende Lage: Im PC befindet sich die erwähnte Hauppauge und eine alte Hauppauge WinTV PCI Karte.
    Den ivtv-Treiber habe ich installiert. (System: Ubuntu 5.10)

    Weder mit Myth, noch Xawtv oder zapping bekomme ich ein Bild hin.

    /var/log/dmesg liefert dazu folgendes:
    [4294714.470000] Linux video capture interface: v1.00
    [4294714.520000] ivtv: ==================== START INIT IVTV ====================
    [4294714.520000] ivtv: version 0.3.8 (tagged release) loading
    [4294714.520000] ivtv: Linux version: 2.6.12-9-386 386 gcc-3.4
    [4294714.520000] ivtv: In case of problems please include the debug info
    [4294714.520000] ivtv: between the START INIT IVTV and END INIT IVTV lines when
    [4294714.520000] ivtv: mailing the ivtv-devel mailinglist.
    [4294714.525000] ivtv: Autodetected WinTV PVR 350 card (iTVC15 based)
    [4294714.526000] ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 16 (level, low) -> IRQ 16
    [4294714.526000] ivtv: Unreasonably low latency timer, setting to 64 (was 32)
    [4294714.623000] tveeprom: Hauppauge: model = 48139, rev = K257, serial# = 7956063
    [4294714.623000] tveeprom: tuner = Philips FM1216 ME MK3 (idx = 57, type = 3
    [4294714.623000] tveeprom: tuner fmt = PAL(B/G) PAL(I) SECAM(L/L) PAL(D/K) (eeprom = 0x74, v4l2 = 0x00400e17)
    [4294714.623000] tveeprom: audio processor = MSP4418 (type = 19)
    [4294714.623000] tveeprom: decoder processor = SAA7115 (type = 13)
    [4294714.623000] ivtv: i2c attach to card #0 ok [client=tveeprom[50], addr=50]
    [4294714.659000] tuner: chip found at addr 0xc2 i2c-bus ivtv i2c driver #0
    [4294714.659000] ivtv: i2c attach to card #0 ok [client=(tuner unset), addr=61]
    [4294714.892000] ivtv: i2c attach to card #0 ok [client=saa7115[50], addr=21]
    [4294714.984000] saa7127 0-0044: saa7129 found @ 0x88 (ivtv i2c driver #0)
    [4294714.986000] ivtv: i2c attach to card #0 ok [client=saa7127, addr=44]
    [4294715.039000] msp34xx: ivtv version
    [4294715.039000] msp34xx: init: chip=MSP3418W-B3, has NICAM support, simple (D) mode, simpler (G) no-thread mode
    [4294715.039000] msp34xx: $Id$ compiled on: Oct 23 2005 15:01:33
    [4294715.378000] ivtv: i2c attach to card #0 ok [client=MSP3418W-B3, addr=40]
    [4294715.411000] tda9885/6/7: chip found @ 0x86
    [4294715.411000] ivtv: i2c attach to card #0 ok [client=tda9887, addr=43]
    [4294716.044000] ivtv: loading /lib/modules/ivtv-fw-enc.bin
    [4294716.075000] ivtv: loading /lib/modules/ivtv-fw-dec.bin
    [4294716.299000] ivtv: Encoder revision: 0x02040011
    [4294716.309000] ivtv: Decoder revision: 0x02020023
    [4294716.310000] ivtv: Allocate DMA encoder MPEG stream: 128 x 32768 buffers (4096KB total)
    [4294716.336000] ivtv: Allocate DMA encoder YUV stream: 161 x 12960 buffers (2048KB total)
    [4294716.358000] ivtv: Allocate DMA encoder VBI stream: 80 x 26208 buffers (2048KB total)
    [4294716.383000] ivtv: Allocate DMA encoder PCM audio stream: 455 x 4608 buffers (2048KB total)
    [4294716.398000] ivtv: Create encoder radio stream
    [4294716.417000] ivtv: Allocate DMA decoder MPEG stream: 16 x 65536 buffers (1024KB total)
    [4294716.430000] ivtv: Allocate DMA decoder VBI stream: 512 x 2048 buffers (1024KB total)
    [4294716.441000] ivtv: Create decoder VOUT stream
    [4294716.447000] ivtv: Allocate DMA decoder YUV stream: 20 x 51840 buffers (1024KB total)
    [4294716.447000] tuner: type set to 38 (Philips PAL/SECAM multi (FM1216ME MK3)) by ivtv i2c driver #0
    [4294717.419000] ivtv: Initialized WinTV PVR 350, card #0
    [4294717.419000] ivtv: ==================== END INIT IVTV ====================
    [4294717.751000] bttv: disagrees about version of symbol tveeprom_hauppauge_analog
    [4294717.751000] bttv: Unknown symbol tveeprom_hauppauge_analog

    Das klingt doch eigentlich gut, oder?

    die Mythtv-logdatei sieht ein wenig gekürzt dagegen so aus:

    ----------------- Start of XMLTV output -----------------
    config file //.mythtv/Videoquelle.xmltv does not exist, run me with --configure
    ------------------ End of XMLTV output ------------------
    Error in 1:1: unexpected end of file
    Updating icons for sourceid: 1
    Updated programs: 0 Unchanged programs: 0
    Failed to fetch some program info
    2005-11-01 05:10:13.392 MainServer::HandleAnnounce Playback
    2005-11-01 05:10:13.412 adding: susi as a client (events: 0)
    2005-11-01 05:10:13.498 MainServer::HandleAnnounce Playback
    2005-11-01 05:10:13.505 adding: susi as a client (events: 1)
    2005-11-01 05:10:13.509 MainServer::HandleAnnounce Playback
    2005-11-01 05:10:13.511 adding: susi as a client (events: 0)
    2005-11-01 05:10:13.592 MainServer::HandleAnnounce Playback
    2005-11-01 05:10:13.594 adding: susi as a client (events: 0)
    2005-11-01 05:10:13.602 adding: susi as a remote ringbuffer
    2005-11-01 05:10:13.697 Changing from None to WatchingLiveTV
    2005-11-01 05:10:14.238 Can't enable VBI recording
    vbi: Invalid argument
    2005-11-01 05:10:25.529 Channel(/dev/video0): CheckChannel failed. Please verify channel "69" in the "setup" Channel Editor.

    ..... gaaaaanz viele solcher Zeilen gelöscht

    2005-11-01 05:10:36.008 Channel(/dev/video0): CheckChannel failed. Please verify channel "E2" in the "setup" Channel Editor.
    2005-11-01 05:10:36.010 Error, couldn't find any available channels.
    2005-11-01 05:10:36.011 Your database is most likely setup incorrectly.
    2005-11-01 05:10:38.052 Changing from WatchingLiveTV to None
    2005-11-01 05:29:06.096 MainServer::HandleAnnounce Playback
    2005-11-01 05:29:06.097 adding: susi as a client (events: 0)
    2005-11-01 05:29:06.105 Reloading backend settings
    2005-11-01 05:29:06.248 MainServer::HandleAnnounce Playback
    2005-11-01 05:29:06.250 adding: susi as a client (events: 1)
    2005-11-01 05:29:47.054 MainServer::HandleAnnounce Playback
    2005-11-01 05:29:47.096 adding: susi as a client (events: 0)
    2005-11-01 05:29:47.214 MainServer::HandleAnnounce Playback
    2005-11-01 05:29:47.216 adding: susi as a client (events: 0)
    2005-11-01 05:29:47.224 adding: susi as a remote ringbuffer
    2005-11-01 05:29:47.235 Changing from None to WatchingLiveTV
    2005-11-01 05:29:47.431 Can't enable VBI recording
    vbi: Invalid argument
    2005-11-01 05:29:54.384 Changing from WatchingLiveTV to None
    2005-11-01 05:30:23.236 Reloading backend settings
    2005-11-01 05:31:54.291 Reschedule requested for id 0.
    2005-11-01 05:31:54.575 Scheduled 0 items in 0.3 = 0.07 match + 0.22 place
    2005-11-01 05:35:53.575 MainServer::HandleAnnounce Playback
    2005-11-01 05:35:53.577 adding: susi as a client (events: 0)
    2005-11-01 05:35:53.595 MainServer::HandleAnnounce Playback
    2005-11-01 05:35:53.596 adding: susi as a client (events: 1)
    2005-11-01 05:35:53.606 MainServer::HandleAnnounce Playback
    2005-11-01 05:35:53.607 adding: susi as a client (events: 0)
    2005-11-01 05:35:53.627 MainServer::HandleAnnounce Playback
    2005-11-01 05:35:53.628 adding: susi as a client (events: 0)
    2005-11-01 05:35:53.637 adding: susi as a remote ringbuffer
    2005-11-01 05:35:53.649 Changing from None to WatchingLiveTV
    2005-11-01 05:35:53.733 Can't enable VBI recording
    vbi: Invalid argument
    2005-11-01 05:35:58.009 Changing from WatchingLiveTV to None
    QSettings: error creating /.qt
    2005-11-01 10:29:49.111 New DB connection, total: 1
    Starting up as the master server.
    2005-11-01 10:29:49.275 New DB connection, total: 2
    2005-11-01 10:29:49.392 Channel(/dev/video0): CheckChannel failed. Please verify channel "3" in the "setup" Channel Editor.
    2005-11-01 10:29:49.401 New DB scheduler connection
    2005-11-01 10:29:49.407 mythbackend version: 0.18.1.20050510-1 www.mythtv.org
    2005-11-01 10:29:49.442 Enabled verbose msgs : important general
    2005-11-01 10:29:51.411 Reschedule requested for id -1.
    2005-11-01 10:29:51.576 Scheduled 0 items in 0.2 = 0.16 match + 0.01 place
    2005-11-01 10:29:51.583 Seem to be woken up by USER
    grmph.

    Kann jemand helfen?
    Wo ist eigentlich meine zweite TV-Karte geblieben?
    Reply With Quote  

  2. Default #2
    laga is offline Cornerstone of the Community
    Join Date
    May 2004
    Location
    Saarland, Germany
    Posts
    2,047
    MythTV Gallery
    0
    Geht mplayer /dev/video0 oder zumindest cat /dev/video0 > /dev/null?

    Schau mal bitte, ob du mehrere tv-eeprom module hast.

    Code:
    cd /lib/modules/`uname -r`/;
    find . | grep eeprom


    www.mythwiki.de - Das deutsche MythTV Wiki!

    [..]denn sie legten die Köpfe auf die Seite und blickten verständig drein, was gerade sogut ist, wie eine Sache verstehen, und sehr viel bequemer. - Oscar Wilde
    Reply With Quote  

  3. Default #3
    lines is offline MythTV Friend
    Join Date
    Nov 2005
    Location
    Ruhrgebiet
    Posts
    30
    MythTV Gallery
    0
    Quote Originally Posted by laga
    Geht mplayer /dev/video0 oder zumindest cat /dev/video0 > /dev/null?

    Schau mal bitte, ob du mehrere tv-eeprom module hast.

    Code:
    cd /lib/modules/`uname -r`/;
    find . | grep eeprom
    Erst mal danke für die Reaktion.

    Gebe ich den Befehl "mplayer /dev/video0" ein, so startet der mplayer und ich erhalte ein "Schneegestöber", so wie bei einem TV bei dem kein Kanal eingegeben ist. Das klingt dann doch schon mal vielversprechend, oder?


    find . | grep eeprom
    liefert das hier:
    ./kernel/drivers/i2c/chips/eeprom.ko
    ./kernel/drivers/media/dvb/ttpci/ttpci-eeprom.ko
    ./ivtv/tveeprom.ko
    Soll das auch so sein?

    Ups, gerade habe ich noch einmal den Befehl mplayer /dev/video0 eingegeben, diesmal mit dieser Fehlermeldung:
    MPlayer dev-CVS--4.0.2 (C) 2000-2005 MPlayer Team
    CPU: Intel (Family: 8, Stepping: 10)
    Detected cache-line size is 64 bytes
    CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled for Debian.


    86 audio & 200 video codecs
    Opening joystick device /dev/input/js0
    Can't open joystick device /dev/input/js0 : No such file or directory
    Can't init input joystick
    Setting up LIRC support...
    mplayer: could not connect to socket
    mplayer: No such file or directory
    Failed to open LIRC support.
    You will not be able to use your remote control.
    Playing /dev/video0.
    Cache fill: 0.00% (0 bytes) Win32 LoadLibrary failed to load: avisynth.dll, /usr/lib/win32/avisynth.dll, /usr/local/lib/win32/avisynth.dll
    XMMS: found plugin: libmpg123.so (MPEG Layer 1/2/3 Player 1.2.10)
    XMMS: found plugin: libwav.so (Wave Player 1.2.10)
    XMMS: found plugin: libmikmod.so (MikMod Player 1.2.10)
    XMMS: found plugin: libcdaudio.so (CD Audio Player 1.2.10)
    XMMS: found plugin: libtonegen.so (Tone Generator 1.2.10)
    XMMS: found plugin: libvorbis.so (Ogg Vorbis Player 1.2.10)
    XMMS: found plugin: libxmmsmad.so (MAD MPEG Decoder plugin 0.
    XMMS: found plugin: libmp4.so (MP4 & MPEG2/4-AAC audio player - 1.2.x)
    XMMS: Closing plugin /usr/lib/xmms/Input/libmp4.so
    XMMS: Closing plugin /usr/lib/xmms/Input/libxmmsmad.so
    XMMS: Closing plugin /usr/lib/xmms/Input/libvorbis.so
    XMMS: Closing plugin /usr/lib/xmms/Input/libtonegen.so
    XMMS: Closing plugin /usr/lib/xmms/Input/libcdaudio.so
    XMMS: Closing plugin /usr/lib/xmms/Input/libmikmod.so
    XMMS: Closing plugin /usr/lib/xmms/Input/libwav.so
    XMMS: Closing plugin /usr/lib/xmms/Input/libmpg123.so
    grummel....


    Reply With Quote  

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. MythTV mit Pinnacle PC-TV Sat Karte und Hauppauge MVP
    By Tomaxx in forum Probleme bei der Installation
    Replies: 1
    Last Post: 04-28-2008, 01:05 PM
  2. MythDVD/MythTV ruckelt mich zu Tode
    By Markus72 in forum Probleme bei der Installation
    Replies: 5
    Last Post: 03-06-2007, 05:15 PM
  3. Welche DVB-S Karte... Hauppauge WinTV NOVA-CI-s ???
    By tommy in forum Hardware (DE)
    Replies: 3
    Last Post: 09-24-2005, 12:57 PM
  4. lirc Verzweifelung
    By MrIch in forum Probleme bei der Installation
    Replies: 3
    Last Post: 03-20-2005, 03:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts